Ajouter un nouveau SDK

De Appmethod Topics
Aller à : navigation, rechercher

Remonter à Gestionnaire de SDK


Outils > Options > Options d'environnement > Gestionnaire de SDK > Ajouter

Gestionnaire de projets | clic droit sur une plate-forme dans Plates-formes cible | Propriétés | Ajouter nouveau SDK (Software Development Kit)


La boîte de dialogue Ajouter un nouveau SDK vous permet d'ajouter un nouveau SDK au Gestionnaire de SDK.

Pour des informations sur le dépannage, voir Gestionnaire de SDK.

Options Description

Sélectionner une plate-forme

Sélectionnez la plate-forme cible pour le SDK. Les fichiers SDK sont alors utilisés pour construire des applications pour cette plate-forme. Voir Plates-formes cible supportées.

Sélectionner un profil à connecter
(Mac OS X et iOS seulement)

Sélectionnez le profil de connexion à connecter au serveur Platform Assistant s'exécutant sur le Mac. Appmethod place les fichiers du SDK dans votre système de développement à partir de la machine spécifiée dans le profil de connexion. Voir Création et test d'un profil de connexion sur le PC de développement.

La liste déroulante contient les profils de connexion existants qui supportent la plate-forme cible. Sélectionnez Ajouter nouveau pour ouvrir l'expert Créer un profil de connexion et créer un nouveau profil de connexion qui supporte la plate-forme cible.

Sélectionner une version SDK

Sélectionnez une version SDK à ajouter à votre système de développement.

La liste déroulante contient les versions des SDK pour la plate-forme cible qui sont fournies par le serveur Platform Assistant (Mac OS X et iOS) ou détectées lors de l'installation dans votre système de développement (Android). La liste des versions SDK disponibles dépend de la plate-forme (et du profil de connexion) sélectionnée précédemment.

Remarque : Pour iOS, la liste déroulante peut contenir des versions non prises en charge du SDK iOS. Ne les sélectionnez pas. Appmethod ne prend pas en charge les versions de SDK iOS antérieures à la version 8.0. Si la liste déroulante ne contient pas de version du SDK iOS prise en charge, vérifiez que la dernière version de Xcode est bien installée sur votre Mac. Voir Installation de Xcode sur un Mac.

Si la liste déroulante est vide ou qu'un SDK attendu manque, voir Gestionnaire de SDK, Dépannage.

Rendre actif le SDK sélectionné

Cochez cette option pour que le nouveau SDK soit le SDK par défaut pour la plate-forme sélectionnée.

Voir aussi